Webhook-Probleme

Fehlerbehebung bei Webhook-Problemen

Hier finden Sie Lösungen für häufige Probleme mit Webhooks.


Webhooks kommen nicht an

Symptom

  • Zahlungsstatus wird nicht automatisch aktualisiert

  • Webhook-Log zeigt keine neuen Einträge

  • Nach Zahlung bleibt Status auf "Open" oder "Pending"

Prüfung

  1. Webhooks aktiviert?

    • Öffnen Sie Mollie Einrichtung

    • Prüfen Sie: "Webhooks aktivieren" = Ja

  2. Webhook-URL konfiguriert?

    • Prüfen Sie das Feld "Webhook URL"

    • URL muss vollständig und korrekt sein

  3. URL erreichbar?

    • Die URL muss öffentlich aus dem Internet erreichbar sein

    • HTTPS ist erforderlich

Lösungen

URL nicht öffentlich erreichbar

Business Central Online:

  • Prüfen Sie die korrekte Tenant-URL

  • Kontaktieren Sie Microsoft Support bei Problemen

Business Central On-Premises:

  • Konfigurieren Sie Port-Forwarding oder Reverse Proxy

  • Stellen Sie sicher, dass HTTPS eingerichtet ist

  • Firewall muss eingehende Verbindungen erlauben

URL-Format prüfen

Die URL sollte diesem Format entsprechen:


Webhooks im Log, aber nicht verarbeitet

Symptom

  • Einträge im Webhook-Log vorhanden

  • Status: "Failed" oder "Ignored"

  • Zahlungsstatus nicht aktualisiert

Prüfung und Lösung

Status: Failed

Öffnen Sie den Log-Eintrag und prüfen Sie die Fehlermeldung:

Fehler
Lösung

"Payment not found"

Payment ID existiert nicht in BC

"Invalid payload"

Daten von Mollie fehlerhaft

"Database error"

BC-Datenbankproblem

Status: Ignored

Der Webhook wurde absichtlich ignoriert:

  • Doppelter Webhook (bereits verarbeitet)

  • Unbekannter Ereignis-Typ

  • Keine Aktion erforderlich


Webhooks verzögert

Symptom

  • Webhooks kommen an, aber mit Verzögerung

  • Status-Updates nicht in Echtzeit

Mögliche Ursachen

  1. Netzwerk-Latenz

    • Normale Verzögerungen von wenigen Sekunden sind üblich

  2. Mollie-Wiederholungen

    • Bei fehlgeschlagener Zustellung versucht Mollie es erneut

    • Das kann zu Verzögerungen führen

  3. Server-Auslastung

    • Hohe Last kann Verarbeitung verzögern

Lösungen

  • Prüfen Sie die Server-Performance

  • Stellen Sie zuverlässige Erreichbarkeit sicher

  • Bei anhaltenden Verzögerungen: Support kontaktieren


Webhook-URL testen

Manueller Test

  1. Öffnen Sie eine Rechnung mit Zahlungslink

  2. Führen Sie eine Testzahlung durch (Test-API-Key!)

  3. Prüfen Sie das Webhook-Log auf Einträge

Erwartetes Ergebnis

  • Neuer Eintrag im Webhook-Log

  • Status: "Processed"

  • Zahlungsstatus der Rechnung aktualisiert


Mollie Webhook-Einstellungen

Webhooks werden pro Zahlung konfiguriert, nicht global in Mollie. Die URL wird beim Erstellen des Zahlungslinks mitgesendet.

circle-info

Sie müssen Webhooks nicht manuell in Mollie konfigurieren. Die Mollie Integration sendet die Webhook-URL automatisch.


Checkliste Webhook-Probleme


Support

Wenn das Problem weiterhin besteht:

Supportkontaktchevron-right

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